h3x.se spotify remote

17Nov/10Off

UPDATE: linux issue (ubuntu 10.10 ?)

New Update(2010.12.04): Messed around a bit on my linux system and a 'smaller' fix is to only install:
'libmono-system-data2.0-cil' it is considerably smaller than 'mono-complete'.

UPDATE: this issue can be fixed by installing 'mono-complete' package. FAQ and installation instructions updated...

Some linux users are experiencing the following issue;

** (./Servify.exe:2746): WARNING **: The following assembly referenced

from /path/to/servify/Newtonsoft.Json.Net20.dll could not
be loaded:
Assembly: System.Data (assemblyref_index=1)
Version: 2.0.0.0
Public Key: b77a5c561934e089
The assembly was not found in the Global Assembly Cache, a path listed
in the MONO_PATH environment variable, or in the location of the
executing assembly (/path/to/servify/).

I'm working to resolve it asap. My suspicion is that the MONO package in ubuntu 10.10 has changed and as a side effect of that, a dependency in Servify is not being met. If my fix is successful I will update the Servify package asap.

Filed under: ReSpot, servify Comments Off
Comments (3) Trackbacks (0)
  1. Hi! First of all, thanks for your great work!

    I got Servify working under Ubuntu 10.04. Unfortunatly installing ‘libmono-system-data2.0-cil’ didn’t solve the issue for me. Installing ‘mono-complete’ (150+ MB of libraries, nice) did do the trick.

    But I’m having some alsa issues. Playing a track after starting Servify works fine, but when I skip to the next track, there is no more music. Servify outputs an error like ‘Error opening ALSA device. ALSA player bailing out.’ I’ll post the exact error next week.

    Is this a known issue? Thnx in advance.

  2. Vincent,

    if you look in the FAQ there’s a few things regarding ALSA in there. However, the next release of Servify will use OpenAL as the backend – hopefully this will resolve the Alsa related issues users are reporting (and surely introduce a slew of new issues… 😀 ).

    I will put in work to improve the installation pages as well, on ubuntu 10.10 the entire mono-complete package should not be needed. There may be another package need too though, will check my notes and post an update later tonight / tomorrow!

  3. Vincent, i checked my notes, and the packages i’ve installed is:
    sudo apt-get install libmono-system-data2.0-cil
    sudo apt-get install libmono-wcf3.0-cil

    Though my dpkg –list shows the following mono related packages also installed:

    ii libmono-addins-gui0.2-cil 0.4-6 GTK# frontend library for Mono.Addins
    ii libmono-addins0.2-cil 0.4-6 addin framework for extensible CLI applications/libraries
    ii libmono-cairo2.0-cil 2.6.7-3ubuntu1 Mono Cairo library (for CLI 2.0)
    ii libmono-corlib2.0-cil 2.6.7-3ubuntu1 Mono core library (for CLI 2.0)
    ii libmono-data-tds2.0-cil 2.6.7-3ubuntu1 Mono Data Library (for CLI 2.0)
    ii libmono-i18n-west2.0-cil 2.6.7-3ubuntu1 Mono I18N.West library (for CLI 2.0)
    ii libmono-management2.0-cil 2.6.7-3ubuntu1 Mono Management library (for CLI 2.0)
    ii libmono-messaging2.0-cil 2.6.7-3ubuntu1 Mono Messaging library (for CLI 2.0)
    ii libmono-posix2.0-cil 2.6.7-3ubuntu1 Mono.Posix library (for CLI 2.0)
    ii libmono-security2.0-cil 2.6.7-3ubuntu1 Mono Security library (for CLI 2.0)
    ii libmono-sharpzip2.84-cil 2.6.7-3ubuntu1 Mono SharpZipLib library (for CLI 2.0)
    ii libmono-sqlite2.0-cil 2.6.7-3ubuntu1 Mono Sqlite library (for CLI 2.0)
    ii libmono-system-data2.0-cil 2.6.7-3ubuntu1 Mono System.Data Library (for CLI 2.0)
    ii libmono-system-messaging2.0-cil 2.6.7-3ubuntu1 Mono System.Messaging Library (for CLI 2.0)
    ii libmono-system-web2.0-cil 2.6.7-3ubuntu1 Mono System.Web Library (for CLI 2.0)
    ii libmono-system2.0-cil 2.6.7-3ubuntu1 Mono System libraries (for CLI 2.0)
    ii libmono-wcf3.0-cil 2.6.7-3ubuntu1 Mono WCF libraries (for CLI 2.0)
    ii libmono2.0-cil 2.6.7-3ubuntu1 Mono libraries (for CLI 2.0)
    ii mono-2.0-gac 2.6.7-3ubuntu1 Mono GAC tool (for CLI 2.0)
    ii mono-csharp-shell 2.6.7-3ubuntu1 interactive C# shell
    ii mono-gac 2.6.7-3ubuntu1 Mono GAC tool
    ii mono-gmcs 2.6.7-3ubuntu1 Mono C# 2.0 and C# 3.0 compiler for CLI 2.0
    ii mono-runtime 2.6.7-3ubuntu1 Mono runtime
    ii ubuntu-mono 0.0.22 Ubuntu Mono Icon theme


Trackbacks are disabled.