h3x.se spotify remote

9May/10Off

New Servify -updated!

Released a new version of Servify. Please test it out and let me know if it works better than before!
Jotify was updated - hope this solves a few of the playlists issues etc.

If you see:
Unknown Command: 0x76 Length: 8
Data: 0.4.3 000105302e342e33
Unknown Command: 0x1f Length: 17
Data: 0000000000000000000000000000000000
in the Servify log, dont worry - it's normal... 😀

Update: this should solve the playlist issue for many users.
If an error such as :
2010.05.10-12:26:33 [ ERROR ] Exception caught! Playlist: c58752238ef5f987e74c364ed5c12dec not loading
2010.05.10-12:26:33 [ ERROR ] java.lang.IllegalArgumentException: Given id is neither a 32-character hex string nor a valid Spotify URI.
at de.felixbruns.jotify.media.Media.(Media.java:73)

Shows up in the logs - it's most likely due to local media being present in your playlist. These playlists will not load properly, but all the others should!

Huge thanks to fxb (creator of jotify).

Filed under: servify Comments Off
Comments (6) Trackbacks (0)
  1. I can’t get me desire to play the songs that i’ve enqueued. I do get the playlists to work though.

    But i’m just keep getting these kind of messages:

    [ WARN ] State: There’s no valid current track:

    What to do?

  2. When first enqueued tracks – dont press the “Play” button, press the track in the queue.. Seems to be a bug in my code! Must fix it.
    Please let me know if this doesnt work for you!

    Actually – no, the play button should work! This error is a strange one… Do you get this every time? Tried re-starting Servify?

  3. Actually, i’ve tried restarting it several times with the same results.. but the track doesn’t start with neither the play button nor the track name..

  4. Interesting. What O/S are you running on the server computer?
    I’ll release a patch tonight which will address a few linux/OS X issues with servify.

  5. I am a looser…

    my IP-adress is 192.168.0.10
    i choose port 1500

    I set this in both ReSpot in my Desire and
    choose 1500 in Servify

    still get “could not connect to servify i/o exception… choosen connection…”

    Svensk?

  6. Nah – that issue can arise for several reasons… unfortunately the hardest one to help out with. anyways;

    After starting servify – make sure that the following is printed;
    2010.05.12-10:09:26 [ INFO ] Servify/J is ready to accept connections!
    2010.05.12-10:09:26 [ INFO ] Listening on port: 1500

    Some more things to check;
    1) wifi enabled on the phone?
    2) firewall disabled / port let through on the server?

    What more you can try is to connect your webbrowser (from some PC on your network, or even the pc running Servify) to “http://192.168.0.10:1500” – a bunch of text should be printed…

    Does any of the above help? Specifically let me know if the PC connecting to servify works!


Trackbacks are disabled.